Cobalt Technology - Lakeside City Power Issue – Incident details

Lakeside City Power Issue

Resolved
Major outage
Started almost 2 years agoLasted 10 minutes

Affected

Lakeside City

Major outage from 7:32 PM to 7:42 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. Power has been restored.

  • Investigating
    Investigating

    We are currently investigating this incident. Power to our Lakeside City tower just went out during the storm. We will provide an update soon.