Cobalt Technology - Extended Power Outage in Iowa Park – Incident details

Extended Power Outage in Iowa Park

Resolved
Major outage
Started over 1 year agoLasted about 2 hours

Affected

Iowa Park ( City Limits)

Major outage from 10:47 AM to 12:52 PM

Iowa Park (Rural-South)

Major outage from 10:47 AM to 12:52 PM

Updates
  • Resolved
    Resolved

    The site is running on generator power now. Driving to the site I saw a dozens of power poles snapped in half and significant storm damage to buildings and trees. I expect it's going to be quite some time before power is restored to the area, so I will keep topping off the generator with fuel until power is restored.

  • Investigating
    Investigating

    Utility power went out yesterday when the storms rolled through. Our towers have robust battery backups, but the power has been out long enough that the battery backups have been fully drained. Oncor is expecting power to be restored around 9 AM, so we are looking into bringing a generator to get service back up while Oncor continues to work.