Cobalt Technology - Power Issue at Iowa Park Rural Tower – Incident details

Power Issue at Iowa Park Rural Tower

Resolved
Major outage
Started over 1 year agoLasted about 1 hour

Affected

Iowa Park ( City Limits)

Major outage from 10:39 AM to 11:24 AM

Iowa Park (Rural-South)

Major outage from 10:39 AM to 11:24 AM

Updates
  • Resolved
    Resolved

    The power issue has been resolved.

  • Investigating
    Investigating

    There appears to be a power issue at our Iowa Park rural tower. A technician is en route to the tower now to assess the situation.