Cobalt Technology - Storm-Related Power Issue on Three-Way Rd Tower. – Incident details

Storm-Related Power Issue on Three-Way Rd Tower.

Resolved
Major outage
Started 19 days agoLasted about 3 hours

Affected

Hwy 79 South Area (Rural)

Major outage from 2:14 PM to 5:27 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. There was a power supply in the tower cabinet that was damaged in the storm. The power supply has been replaced and everything on the tower is back online.

  • Investigating
    Investigating

    We are currently experiencing a power issue on our three-way Rd tower due to the storms. We will provide updates as we know more. Expected restoration time is 2 PM.